Outage of core services affecting Airtable and Excel integrations

Major incident Glide Apps General Glide Builder General
2022-04-20 18:00 UTC · 16 minutes

Updates

Resolved

Service should be restored, we are continuing to monitor.

April 20, 2022 · 18:17 UTC
Issue

Glide is currently experiencing an outage impacting Airtable and Excel integrations. Data from these integrations may be unavailable at this time.

April 20, 2022 · 18:02 UTC

← Back