Issue with new sign ups

Minor incident Glide Builder Login
2021-06-03 21:35 UTC · 23 minutes, 10 seconds

Updates

Resolved

Services should be working normally

June 3, 2021 · 21:58 UTC
Issue

Glide currently cannot accept new sign ups. We are investigating the issue.

June 3, 2021 · 21:36 UTC

← Back