Degraded Performance

Minor incident Glide Apps General Login
2021-05-06 16:54 UTC · 30 minutes, 33 seconds

Updates

Resolved

Things should be back to normal :)

May 6, 2021 · 17:25 UTC
Issue

We are currently experiencing a minor service disruption. Most apps and features should be working with intermittent issues with most of Glide’s services. Private apps may experience some issues with authentication.

May 6, 2021 · 16:56 UTC

← Back