Outage

Minor incident Glide Apps Login Google Sheets Sync Glide Builder General Login
2020-12-29 01:48 UTC · 4 hours, 18 minutes, 10 seconds

Updates

Resolved

All issues are resolved

December 29, 2020 · 06:06 UTC
De-escalate

Full services are coming back online now.

December 29, 2020 · 04:51 UTC
Update
  • App functionality is restored.
  • Builder remains down.
  • Sign in with google does not work, sign in with pin works.
  • Sheet sync to google is down.
December 29, 2020 · 03:55 UTC
Issue

Glide is experiencing a major service disruption.

December 29, 2020 · 01:49 UTC

← Back