DNS issues with the glide.page domain
Minor incident
Apps
General
2026-04-18 22:29 UTC
· 57 minutes
Updates
Resolved
April 18, 2026 · 23:24 UTC
The DNS issue has been resolved, and apps are accessible again. If you’re still unable to access your app, try clearing your browser cache. If the issue persists, it may take additional time for your ISP’s DNS servers to update. In the meantime, you can access your app using the glide.app domain.
Issue
April 18, 2026 · 22:29 UTC
We’re looking into issues where published apps using the glide.page domain aren’t resolving. A workaround is to use <app>.glide.app for now.
← Back