Email deliverability issues

Minor incident Apps Login Integrations Builder Login
2026-02-24 17:54 UTC · 7 hours, 1 minute

Updates

Resolved

Email delivery has returned to normal

February 25, 2026 · 00:55 UTC
De-escalate

We’re still observing email delivery issues with GMail accounts. Glide continues the investigation.

February 24, 2026 · 20:17 UTC
Investigating

We’re currently investigating an issue affecting email deliverability to some recipients. As a result, some emails may be delayed or temporarily not delivered.

We’re actively working on mitigation and will share updates as we learn more.

February 24, 2026 · 17:54 UTC

← Back