Email deliverability problems

Minor incident Apps Login Builder Login
2026-01-28 13:11 UTC · 18 minutes

Updates

Resolved

We identified an issue with a third-party provider and were able to solve it.

January 28, 2026 · 13:29 UTC
Issue

We’re investigating an issue with emails not being delivered.

January 28, 2026 · 13:11 UTC

← Back