Builder and apps present "Service Unavailable"

Major incident Apps General Login Custom Domains Integrations Data Glide Big Tables Glide Tables Airtable Sync Google Sheets Sync Excel Sync Workflows General Builder General Login Templates
2025-08-28 20:07 UTC · 3 hours

Updates

Resolved

All Glide services have recovered; Glide will continue to monitor.

August 28, 2025 · 23:07 UTC
Monitoring

The service is coming back online, though you may continue to experience some slowness. If issues persist, please contact our support team.

August 28, 2025 · 21:43 UTC
Update

The Glide service is currently experiencing disruptions due to issues with one of our upstream service providers.

August 28, 2025 · 20:16 UTC
Investigating

Engineering is looking into an issue where accessing the Builder and published apps is reporting “Service Unavailable”.

August 28, 2025 · 20:07 UTC

← Back