Player and builder intermittently failing to load

Minor incident Apps General Login Custom Domains Integrations Data Glide Big Tables Glide Tables Airtable Sync Google Sheets Sync Excel Sync Workflows General Builder General Login Templates
2025-06-12 18:09 UTC · 10 hours, 34 minutes

Updates

Resolved

Glide has fully recovered.

June 13, 2025 · 04:43 UTC
Monitoring

Glide is continuing to recover. However, we are still experiencing long data sync times (if you are syncing with an external source).

June 12, 2025 · 21:33 UTC
De-escalate

Glide should be accessible to all customers and we will continue to monitor as services return to normal. We expected some degraded performance as our upstream provider recovers.

June 12, 2025 · 20:34 UTC
Monitoring

We continue to monitor the third-party service outage. Once they come back online, it will take time for Glide to bring its service back up. All apps and workflows are potentially impacted.

June 12, 2025 · 20:06 UTC
Update

Glide should be accessible to all customers and we will continue to monitor as services return to normal. We expected some degraded performance as our upstream provider recovers.

June 12, 2025 · 19:05 UTC
De-escalate

We are actively monitoring the recovery process. Some services work but many are still coming online.

June 12, 2025 · 19:02 UTC
Investigating

Our downstream platform provider is currently experiencing a large outage which is impacting Glide. We are in contact with them to determine the scope and status — we will update this issue as we know more.

June 12, 2025 · 18:23 UTC
Investigating

Our team is currently investigating issues connecting with Glide.

June 12, 2025 · 18:09 UTC

← Back