Team Invite requests failing

Minor incident Builder General
2025-06-03 22:42 UTC · 17 hours, 20 minutes

Updates

Resolved

This issue has been resolved. Thank you for your patience.

June 4, 2025 · 16:01 UTC
Investigating

Glide has identified the root cause and is working on releasing a fix.

June 4, 2025 · 00:13 UTC
Investigating

Glide has been made aware that invited users are unable to accept invitations and is currently investigating.

June 3, 2025 · 22:42 UTC

← Back