Performance degradation

Minor incident Apps General Integrations Data Glide Big Tables Glide Tables Airtable Sync Google Sheets Sync Excel Sync Workflows General Builder General Templates
2025-05-02 18:05 UTC · 1 hour, 25 minutes

Updates

Resolved

Systems are back to normal operation. We thank you for your patience while we respond to abnormal traffic patterns.

May 2, 2025 · 19:28 UTC
Investigating

We are addressing the issue by adjusting system resources. Apps and the Glide builder are beginning to return to normal operation. We will monitor the return to normal operation and post a final update.

May 2, 2025 · 18:27 UTC
Investigating

We’re investigating degraded performance in our platform due to a surge in activity.

May 2, 2025 · 18:05 UTC

← Back