Glide is experiencing some builder slowness

Minor incident Builder General
2025-04-25 18:23 UTC · 1 hour, 15 minutes

Updates

Resolved

This issue has been resolved.

April 25, 2025 · 19:38 UTC
Investigating

We are investigating the root cause and will update status shortly.

April 25, 2025 · 18:23 UTC

← Back