Some "glide.page" apps unable to load in certain regions

Minor incident Apps General Login
2025-03-19 14:35 UTC · 4 days, 9 hours, 46 minutes

Updates

Resolved

We have provisioned glide.app as an alternative domain that can be used as a drop-in replacement for glide.page. If you or your customers are experiencing issues accessing apps on the glide.page domain, you may now direct them to use glide.app.

The two domains can be used interchangeably, so you only have to let affected customers know of the new domain option without having to tell your whole customer base.

Customers that have saved app bookmarks or web shortcuts will have to re-install them to update the linked domain.

March 24, 2025 · 00:04 UTC
Update

We continue to work on an alternative solution for affected applications.

Customers wishing to avoid the issue can utilize a custom domain, which will avoid this specific DNS issue.

March 20, 2025 · 23:29 UTC
Investigating

We are continuing to work with upstream providers to resolve the issue.

March 19, 2025 · 21:04 UTC
Issue

A small number of apps on the glide.page domain are unavailable for some users, returning SSL errors in specific regions.

We have identified this to be a sporadic DNS issue and we are currently working to resolve the issue and provide alternative methods of accessing your apps.

In the meantime, accessing affected applications via a custom domain will avoid the issue all together.

March 19, 2025 · 20:35 UTC

← Back