Email Sending Disruption

Minor incident Apps General
2025-03-19 15:42 UTC · 18 hours, 26 minutes

Updates

Update

We’ve noticed a related issue that is still preventing delivery. We are working to restore service as quickly as possible.

March 20, 2025 · 10:31 UTC
Update

Emails for logging in to the builder should be working again.

March 19, 2025 · 21:04 UTC
Investigating

We are continuing to work with our provider to address email delivery delays. We will provide additional information as soon as it becomes available from the provider.

March 19, 2025 · 18:38 UTC
Investigating

We’ve identified that one of our email sending providers is currently down, causing outgoing emails to fail. We’re in contact with the provider and working on implementing a workaround to restore service.

March 19, 2025 · 16:14 UTC
Investigating

This is also affecting the Builder Sign-In; the Glide team is investigating.

March 19, 2025 · 15:54 UTC
Investigating

We’re currently experiencing an issue where outgoing emails are failing to send. Our team is investigating the root cause and working to resolve it as quickly as possible.

March 19, 2025 · 15:42 UTC

← Back