Email delivery failures

Minor incident Glide Apps Login Glide Builder Login
2024-10-11 20:40 UTC · 3 weeks, 2 days, 18 hours, 45 minutes

Updates

Resolved

Email deliverability has returned to normal levels of success.

November 4, 2024 · 15:25 UTC
Issue

Glide is aware that emails destined for Microsoft Outlook are not being received. Glide is working to mitigate this issue and will update the status once there is a clear resolution.

October 11, 2024 · 20:40 UTC

← Back