Glide Player is experiencing an Outage

Major incident Glide Apps General Login Custom Domains Google Sheets Sync Excel Sync Airtable Sync
2024-01-25 01:02 UTC · 21 minutes

Updates

Resolved

Glide Apps are back to normal. We’ll be monitoring.

January 25, 2024 · 01:23 UTC
Issue

We’re investigating connection issues accessing Glide Apps

January 25, 2024 · 01:02 UTC

← Back