Performance issues when accessing the Glide builder

Major incident Glide Apps Google Sheets Sync Excel Sync Airtable Sync 3rd Party Integrations Airtable Sync
2023-11-11 19:26 UTC · 1 hour, 19 minutes

Updates

Resolved

Glide operations are returned to normal.

November 11, 2023 · 20:45 UTC
Investigating

Service should be restored, syncs are still delayed.

November 11, 2023 · 20:07 UTC
Investigating

Glide is now experiencing a major outage in all services.

November 11, 2023 · 19:41 UTC
Investigating

We are investigating performance issues connecting to the Glide builder. Next update in 30 minutes.

November 11, 2023 · 19:26 UTC

← Back