Data sync issues for some apps using Airtable or Excel

Minor incident Glide Apps Excel Sync Airtable Sync
2023-10-13 17:03 UTC · 4 days, 4 hours, 54 minutes

Updates

Resolved

At this time, we continue to observe that certain Airtable bases, particularly those with higher row counts, are having trouble syncing with Glide.

This is due to the Airtable API rate limits recently imposed by Airtable. We are continuing to gather data about exactly what shape of Airtable tables are encountering these rate limits.

If you are continuing to experience issues syncing large bases, we recommend considering an upgrade to Airtable Business or a higher Airtable plan, which we understand to have higher API limits and a higher chance of a timely sync.

Glide supports up to 25k records for Airtable-connected apps. If your base contains more than 25k records, try to reduce the number of records in the connected base by archiving unused records, or moving tables to another base if not needed in your Glide app.

October 17, 2023 · 21:52 UTC
Update

We continue to work on remediations that help Glide to be more resilient to Airtable API rate limits. We are rolling this out as quickly, but as safely as possible. Glide will continue to update this issue as we make meaningful progress.

October 17, 2023 · 19:56 UTC
Issue

The Glide team is aware of and actively working on resolving data sync issues for some customers with apps connected to Airtable or Excel. We identified and fixed an issue that caused some apps to break their connections to these data sources. Our data fallback process has stored these unsynced data changes in Glide tables.

We recommend all customers using Airtable or Excel to check the Data Editor. If you see your Airtable or Excel tables with the Glide tables icon, it means that your app was affected. Changes to your data are being written to these tables and not being synced back to your external data source. We are currently investigating whether we can sync these changes with Airtable and Excel.

If you see your Airtable or Excel tables with the appropriate icons, your app was not affected. Your data should be syncing to your external data sources as normal.

October 13, 2023 · 17:03 UTC

← Back