Airtable and Excel connection(s)

Major incident Glide Apps General Login Custom Domains Google Sheets Sync Excel Sync Airtable Sync 3rd Party Integrations Airtable Sync
2023-10-13 12:17 UTC · 4 hours, 59 minutes

Updates

Resolved

Out of an abundance of caution to avoid any possible data loss, we are working to reach out to each of the customers that have been affected by this incident to confirm that our data source reconnection plan for their affected apps is sound.

Glide can also confirm that no unintentional Airtable disconnects are occurring at this time. We are aware, however, that some syncs with Airtable are no longer happening on a timely basis. As such we are downgrading this incident at this time.

October 13, 2023 · 17:08 UTC
Update

We are continuing our work to restore connections. We will provide a next update in 1 hour.

October 13, 2023 · 15:42 UTC
Update

Glide is asking customers with broken or disconnected external datasources to allow Glide time to mitigate these connection issues. In order to avoid additional data state complications, please do not attempt to mitigate these issues yourself at this time. We are aware of continued delays in syncing with external data sources. Glide will provide an update as soon as possible.

October 13, 2023 · 14:41 UTC
Update

Yesterday we deployed changes to our external data source sync engine in response to some recently announced Airtable API rate limiting changes. The goal of our changes was to ensure Glide apps with Airtable data sources were able to sync in a timely fashion with Airtable.

While rolling out these changes, we encountered unfortunate adverse side effects:

Our current understanding is that Airtable tables have been disconnected from Glide apps for certain customers. Of these affected customers, a subset will see that new Glide tables were created in an unexpected fashion.

For customers affected by this data source connection issue, syncing to Airtable tables is not possible at this time.

We are also investigating Excel connections, which we believe to be affected.

The engineering team is working to restore table connections between Glide and Airtable tables as they existed at approximately 2023-10-12 20:00:00 UTC.

We apologize for the disruption to your business operations, and are working hard to restore the functionality you expect.

October 13, 2023 · 13:45 UTC
Investigating

We are continuing our work to restore connections. We will provide a further update by 14:00 UTC.

October 13, 2023 · 13:02 UTC
Investigating

We have identified the root cause of some apps being disconnect from Airtable and Excel. We are currently working to restore these connections.

October 13, 2023 · 12:17 UTC

← Back