Service degradation

Major incident Glide Apps General Login Custom Domains Google Sheets Sync Glide Builder General Login Excel Sync Airtable Sync
2023-09-24 00:25 UTC · 50 minutes

Updates

Resolved

We are satisfied we have shutdown the main attacking actor and Glide is now working normally.

September 24, 2023 · 01:10 UTC
Monitoring

We have implemented a mitigation that seems to be working very well. Apps and Builder should now be reachable and performance should return to normal shortly.

September 24, 2023 · 01:00 UTC
Investigating

Glide appears to be under a sustained DDoS attack, performance remains degraded and we are investigating mitigations.

September 24, 2023 · 00:42 UTC
Issue

Glide is experiencing performance degradation. Apps and builder maybe unreachable or very slow to load.

September 24, 2023 · 00:25 UTC

← Back