AirTable and Excel synchronization issues

Minor incident Glide Apps Excel Sync Airtable Sync
2023-08-22 16:18 UTC · 1 week, 5 hours, 21 minutes

Updates

Resolved

This issue has been resolved. AirTable and Excel updates are completing successfully.

August 29, 2023 · 21:38 UTC
Issue

AirTable and Excel are both experiencing delays in synchronization. Our team has already tracked down the issue and are working on a fix.

August 29, 2023 · 16:14 UTC

← Back