Degraded sheet reload performance and AirTable outage

Minor incident Glide Apps Google Sheets Sync Excel Sync Airtable Sync 3rd Party Integrations Airtable Sync
2023-07-18 18:39 UTC · 45 minutes, 1 second

Updates

Resolved

Upstream issues have resolved and downstream impacts are recovered.

July 18, 2023 · 19:23 UTC
Monitoring

AirTable is experiencing a major outage at the moment. This is having downstream effects on Glide and we expect to see delays in sheet and data processing.

July 18, 2023 · 18:39 UTC

← Back