Glide is sometimes unable to load data from your spreadsheet

Minor incident Glide Apps Google Sheets Sync
2020-04-17 17:48 UTC · 1 week, 6 hours, 3 seconds

Updates

Resolved

The incident has been resolved.

April 24, 2020 · 23:48 UTC
Investigating

Due to an increase in usage, Glide occasionally and temporarily exceeds Google’s quotas for loading Sheets, so apps may be unable to load sheets for an hour or more.

In most cases, Glide will continue trying to reload your sheet and eventually succeed, so the problem usually resolves on its own.

We are working with Google to increase Glide’s global quotas.

April 18, 2020 · 17:53 UTC

← Back