Apps are slow or fail to load in SE Asia, Australia

Minor incident Glide Apps General
2020-04-18 17:06 UTC · 3 hours, 15 minutes, 59 seconds

Updates

Resolved

Upstream service has been resolved.

April 18, 2020 · 20:22 UTC
De-escalate

Issues loading apps in SE Asia and Australia should be clearing up. We are closely monitoring the situation.

April 18, 2020 · 17:30 UTC
Investigating

We have detected issues and we are currently investigating, we’ll update you soon.

April 18, 2020 · 17:07 UTC

← Back