Glide is experiencing a partial outage

Minor incident Glide Apps General Login Custom Domains Google Sheets Sync Glide Builder General Login
2023-01-13 20:42 UTC · 20 minutes

Updates

Resolved

The original issue wherein a large volume of requests was made to our service in a short period of time, has subsided. We will continue investigating how our systems became unavailable due to this shape of request volume.

January 13, 2023 · 21:03 UTC
Issue

We’ve received automated alerts that some customers may be unable to access Glide.

January 13, 2023 · 20:43 UTC

← Back