Syncing is delayed between Glide Tables and Google Sheets

Minor incident Glide Apps General Google Sheets Sync
2022-11-21 16:32 UTC · 6 hours, 4 minutes

Updates

Resolved

We have confirmed that all systems are working as expected now. Customers that were seeing inaccurate pricing quotas based on the Google Sheets and Glide Tables syncing delays should now see their quotas restored.

November 21, 2022 · 22:37 UTC
Update

Google Sheets and Glide Table sync should now be functioning as expected for the majority of customers that were affected. We are still monitoring a few outlier accounts that are affected, and expect to see those delayed queues to catch up over the next 1-2 hours.

November 21, 2022 · 20:27 UTC
Monitoring

We are seeing backed up queues that process Google Sheets updates beginning to improve.

November 21, 2022 · 17:31 UTC
Monitoring

Our rollback deployment has been completed. We are now monitoring to verify that affected services begin stabilizing with the fix applied.

November 21, 2022 · 17:06 UTC
Update

Our rollback deployment is still in flight, and we expect this to complete within the next 10 minutes.

November 21, 2022 · 17:01 UTC
Update

We believe we have identified the root cause of the issue leading to syncing delays between Glide Tables and Google Sheets. We are in the process of rolling back the change that we believe introduced a regression.

November 21, 2022 · 16:44 UTC
Investigating

We’ve received reports from customers that syncing of writes between Google Sheets and Glide Tables is delayed.

We’re also investigating related reports of inaccurate quota usage related to pricing.

November 21, 2022 · 16:38 UTC

← Back