Email pins slow to deliver

Minor incident Glide Apps Login
2022-09-21 18:24 UTC · 1 hour, 4 minutes

Updates

Resolved

A fix has been implemented and we are monitoring results.

September 21, 2022 · 19:28 UTC
Issue

We have observed an issue with emails taking a while to send and are investigating.

September 21, 2022 · 18:25 UTC

← Back